- お知らせ -
  • 当wikiのプログラムコードの表示を直してみました(ついでに長い行があると全体が下にぶっ飛ぶのも修正)。不具合があればBBSまでご連絡下さい。

NinjaTrader

はじめに Edit

NinjaTraderにヒストリカルデータをインポートしたい話。

対象は主にNinjaTrader 6.5です。

ヘルプにも記載有り。
.chmでは目次の"Historical Data"→"Import"からたどれます。
オンラインヘルプでは、"Import - NinjaTrader Version 6 Help Guide" を参照のこと。

具体的な手順 Edit

  • Tools→InstrumentManager で銘柄を作成
    (作成しとかないと、ファイル名から自動的に決まっちゃう)
  • 指定のフォーマットに整形したファイルを用意
    ファイル名は、InstrumentManager で生成したものにあわせましょう。
  • Tools→Historical Data→Import... でデータのファイルを指定
  • 後はチャートでインポートした銘柄を開けばOK!!

FAQ Edit

インポートは成功したが、チャートに出てこないよ! Edit

表示するデータの範囲を確認しましょう。

"Bars back"でさかのぼるバーの数を指定、もしくは"Start date"で表示する日付の範囲を直接指定します。

チャート表示してからの範囲の変更は、チャート左から2番目の"1 Min"とか "Daily"とかの表示をクリック→(一番下)Format Data Series... を選択すると、変更できます。

フォーマット Edit

ヘルプみてくれ、という感じですが、一応解説。

[TODO]:フォーマットを簡単に書く

参考リンク Edit

  • Pan; ニンジャトレーダー入門
    サンプルの日経225先物のデータのインポート方法の解説が少しあります。
    (ただし、サンプルはイブニングセッションのデータを含むダメダメデータw)

No comment. Comments/NinjaTrader/ヒストリカルデータのインポート方法?

Name:

Front page   Edit Freeze Diff Backup Upload Copy Rename Reload   New Pages Search Recent changes   Help   RSS of recent changes
Last-modified: 2009-09-18 Fri 11:43:32 JST (2983d)